用「相容性模式」安裝、執行不支援的舊版軟體

如果你剛升級成Windows Vista的話,可能會發現一些原本慣用的軟體到了Vista系統中卻無法正常安裝使用,他會出現不支援Vista的錯誤而終止安裝程序。一般遇到這種情況的話,,

必須得等軟體原廠推出支援Vista系統的新版軟體,才能繼續使用。如果你用的軟體已經不再出新版、甚至已經找不到原開發廠商,那該怎麼辦呢?

繼續閱讀

以下我們以Windows Vista中的「相容性模式」來執行暫時無法在Vista系統中運作的程式,大部分問題不大的小程式或軟體應該都可以用「相容性模式」來安裝、操作。目前可支援的舊版系統環境為Windows 95、Windows 98/Me、Windows NT 4.0 SP5、Windows 2000、Windows XP SP2、Windows Server 2003 SP1...等。另外還可自行設定運行時的螢幕解析度、螢幕色彩…等,避免因為某些舊版軟體只支援較少的色彩或不支援圖形主題...等情況。

這個「相容性模式」雖然可以支援大部分小程式或軟體,但如果是一些防毒軟體、系統管理、修改程式或磁碟管理軟體...等,則有可能因為系統規格與環境差異太大而造成當機、軟體執行錯誤或Vista系統毀損,如果是這類軟體則不可以用「相容性模式」來執行。

 

一、無法在Windows Vista系統中安裝的軟體

如圖,如果你要執行或安裝某個軟體時,出現類似「This operating system is not supported!」的訊息,表示這軟體無法在Windows Vista系統中執行。如果這軟體不是防毒軟體、系統修改程式或其他磁碟管理軟體…等,可以用下面的「相容性模式」來執行看看。

14-00-37

 

 

二、使用「相容性模式」來執行程式

第1步  請在軟體安裝檔上按一下滑鼠右鍵,再點選【內容】。

14-00-57

 

第2步  切換到〔相容性〕功能頁面,先勾選「以相容性模式執行這個程式」,然後在下拉選單中點選該軟體原本適用的作業系統,如「Windows XP (Service Pack 2)」,設定好之後,再按一下〔確定〕按鈕。

14-01-05

 

第3步  如圖,勾選好相容性模式的選項後,當我們再執行剛剛的安裝檔就可順利將軟體安裝到電腦中囉。

14-01-22

最後更新:09-14, 2013 上午 11:26

TAG:
相關資訊

訪客留言:

20 Replies to “用「相容性模式」安裝、執行不支援的舊版軟體”

  1. 請問軟体在WIN7可以點選相容WIN2000, 但WIN8版本無相容WIN2000選項, 所以RUN系統 無法找到 連線網路磁碟機, 請問有何解決方法.

  2. 想請問我的是xp系統,有個程式勾選相容式windows2000卻不能使用怎麼辦,謝謝?>?
    是什麼原因,但有些電腦勾了卻可以使用??

  3. 謝謝布萊恩提供了很多資訊,
    不過有些軟體還是無法以相容性的方式執行,
    還是很謝謝你啊

發佈留言

發佈留言必須填寫的電子郵件地址不會公開。

Facebook 留言板